TWO-STROKE POTPOURRI: MR KNOW-IT-ALL

BAFFLED
Dear Mr. Know-It-All,
I have a 2002 KX250. I love the bike, but recently it has started running very rich. It’s not losing transmission oil, so I know the crank seal is okay, and I’ve played with a million needles and pilot jets and still can’t get the bike to clean up. Is there something worn out that is beyond my expertise?
“Green Rager”
Via [email protected]

I’m sure a lot of things are beyond your expertise, but without bludgeoning you into a single-celled organism, here’s my advice. One of the many overlooked items in a Keihin carb on that era of two-stroke is the jet block O-ring. Where your pilot and main jet are located, there is a removable aluminum block that has two security Torx screws holding the jet block in place. Underneath the jet block is an O-ring. The jet block has multiple passages, and the O-ring protects the carburetor’s main body from excess fuel feeding into the circuits. If the O-ring fails, the machine will be getting more fuel than needed into the pilot circuit and main jet, essentially making it run rich. I’ve even seen these gaskets deteriorate to where the rubber is blocking the passages in the jet block, also causing huge jetting issues. Unfortunately, I can’t guarantee that this is your dilemma, but it is a good place to start.

BEARING WOES
Dear Mr. Know-It-All,
I recently did a top end on my 2001 YZ125. I had the cylinder re-plated and a Wiseco piston fit to the size of the bore. When I tore it apart before the top end, the piston had lots of scoring. Now, after the first initial ride, I pulled my exhaust and looked into the cylinder to find the same score marks on the piston. Did the company not set the clearance correctly on the new bore?
Sean Monatt
Via [email protected]

To be honest, Sean, you’re a wee bit lean on providing some intel here. So, I’m going to brainstorm a skosh and surmise that your issue lies elsewhere, mainly south of the top end. Frankly, one would think that your machine would sound like it had a fistful of ball bearings internally. I believe that the bottom end of your steed has been invaded by a foreign enemy, most likely material from a bearing going rogue or the plating wearing off the pin that connects the big-end bearing. Your only option is to peel it apart and search for the intruder. 

Comments are closed.